stevepedwards.com/DebianAdmin linux mint IT admin tips info

Cisco Setup – ADSL Connection (WAN)

I can't write this Post to WP as I go because I don't have 2 phone lines to use (!!), so I won't have a working internet connection for LAN access via the Cisco until many sections are set up fully.

Below, I add the minimum needed key sections of the config file that enable WAN connectivity only - logging in to the ISP account and being allocated an IP address only at this point - which is complex to fully understand or explain from bare line levels upwards as it involves layer 1-3 protocols and Cisco CCNA level study - to even partly appreciate, let alone how Cisco's commands enable them - such as Point to Point Protocols (PPP), Asynchronous Transfer Mode (ATM), PPPoA (over ATM for telephone circuits)  PPPoE (over Ethernet e.g. for VDSL routers over cable/fibre etc.), aal5snap for virtual circuits etc. Look them up on Google. I can't possibly explain all of the settings as mine were taken from various conf files and Cisco examples also.

There are two main sections to a serial ADSL connection - a "real" hardware ATM connector and a "virtual dialer" (yes, from dial up modem/ISDN days) that control the overall process of creating and managing a data circuit over a phone line.

From my working config, the ATM section has key points to note for YOUR line/ISP that are in bold and may be understood (or not!) in context later. Without much research, it is not possible to understand all of the Cisco command functions and just accept they are or may be needed for required operations to work:

interface ATM0
no ip address 
ip nat outside
ip virtual-reassembly
logging event atm pvc state
logging event atm pvc autoppp
no atm ilmi-keepalive
dsl operating-mode auto adsl2 adsl2+
dsl enable-training-log
!
interface ATM0.1 point-to-point
ip address dhcp
ip nat outside
ip virtual-reassembly
no snmp trap link-status
atm route-bridged ip
atm pppatm link reset
pvc 0/38
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
ip addr inarp
!

For the user, a most important thing to know for your country/ISP is the PVC number (Permanent Virtual Circuit), which for BT in the UK is 0/38.

Note the similar features as linux ethernet sub-interfaces are possible also using a decimal point system:

cisco877# sh interfaces atM 0.?
<0-4294967295> ATM interface number

The section from my working conf that handles dial out settings such as account login details is:

interface Dialer1
ip address negotiated previous
ip access-group BLOCKWAN in
ip nat outside
ip nat enable
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
autodetect encapsulation ppp
ppp authentication chap pap callin
ppp chap hostname user@plus.net
ppp chap password 7 03174F0E10.....
ppp ipcp wins request
ppp ipcp mask request
ppp ipcp route default
ppp ipcp address accept

You can attempt to get the same IP address from your ISP you had at last login:

ip address negotiated previous

cisco877# conf t

cisco877(config)# interface dialer 1

cisco877(config-if)# ip address negotiated ?
previous IPCP attempts to negotiate previous address assigned

Let's input these sections line by line - starting in the relevant interface sub directory - to the unit; save the config then connect it to the phone line and see what happens...note the named BLOCKWAN ACL has been applied to the interface but is not yet written in the conf! That's is the next Post.

cisco877# conf t

cisco877(config)# interface dialer 1

cisco877(config-if)# ip address negotiated previous
ip access-group BLOCKWAN in
ip nat outside
ip nat enable
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
autodetect encapsulation ppp
ppp authentication chap pap callin
ppp chap hostname user@plus.net
ppp chap password 7 03174F0E100A244A4210090243
ppp ipcp wins request
ppp ipcp mask request
ppp ipcp route default
ppp ipcp address accept

Now for the ATM sections:

cisco877(config-if)# exit

cisco877(config)#interface ATM0
ip nat outside
ip virtual-reassembly
logging event atm pvc state
logging event atm pvc autoppp
no atm ilmi-keepalive
dsl operating-mode auto adsl2 adsl2+
dsl enable-training-log

cisco877(config-if)# interface ATM0.1 point-to-point
cisco877(config-subif)# ip address dhcp
ip nat outside
ip virtual-reassembly
no snmp trap link-status
atm route-bridged ip
atm pppatm link reset
pvc 0/38
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
ip addr inarp

cisco877(config-if-atm-vc)# end

Save the config:

cisco877# copy running-config startup-config

Destination filename [startup-config]?
Building configuration...
[OK]

 

AND NOW - For the MOST COMMON CISCO FAULT...!!!

The user forgetting to enable the interfaces!!!

cisco877(config)# interface atM 0 

cisco877(config-if)# no shutdown

cisco877(config)# interface dialer 1

cisco877(config-if)# no shutdown

Now plug the 877 ADSL port into the phone line, listen for the relays to click and watch for WAN connections:

To view atm0 line stats when dsl enable-training-log is enabled:

cisco877# sh dsl interface aTM 0

DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 12089 0 1131

To prove an ISP connection has been made, my static IP address has been allocated to Dialer1 - which of course, I have to hide, and Internet Protocol Control Protocol (IPCP) is up on that interface:

cisco877# sh ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0 unassigned YES unset up up
FastEthernet1 unassigned YES unset up down
FastEthernet2 unassigned YES unset up down
FastEthernet3 unassigned YES unset up down
Dot11Radio0 unassigned YES NVRAM administratively down down
ATM0 unassigned YES NVRAM up up
ATM0.1 unassigned YES DHCP up up
Vlan1 192.168.1.100 YES NVRAM up up
NVI0 unassigned NO unset up up
Dialer1 x.x.x.x YES IPCP up up
Virtual-Access1 unassigned YES unset up up
Virtual-Access2 unassigned YES unset up up

I cannot use the unit fully at this point for Web access as no Default Gateway, NAT, DNS, LAN DHCP server or ACLs have been set, so no traffic can be sent or received.

Summary Conf with LAN and WAN connections set only and non bold Cisco auto added functions:

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco877
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$e/g3$ceiyt/4dt/GK9gSm7vbkN.
enable password 7 03145404161F2E435E
!
no aaa new-model
no ip routing
no ip cef
!

multilink bundle-name authenticated
!
!
interface ATM0
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache
logging event atm pvc state
logging event atm pvc autoppp
no atm ilmi-keepalive
dsl operating-mode auto adsl2 adsl2+
dsl enable-training-log
!
interface ATM0.1 point-to-point
ip address dhcp
ip nat outside
ip virtual-reassembly
no ip route-cache
no snmp trap link-status
atm route-bridged ip
atm pppatm link reset
pvc 0/38
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
ip addr inarp
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 192.168.1.100 255.255.255.0
no ip route-cache
!
interface Dialer1
ip address negotiated previous
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
autodetect encapsulation ppp
ppp authentication chap pap callin
ppp chap hostname user@plus.net
ppp chap password 7 071C3549580C1C031B0B1B0B50
ppp ipcp wins request
ppp ipcp mask request
ppp ipcp route default
ppp ipcp address accept
!
!
!
no ip http server
no ip http secure-server
!
snmp-server community public RO
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password 7 051B090031
login
!
scheduler max-task-time 5000
end

Comments are closed.

Post Navigation